
 

 
Practical Applications of PartMaker 
SwissCAM Machining Function Face 
Windows for Live Tooling Operations 

Introduction 
This appendix to the PartMaker SwissCAM User Manual is intended to give you, the user, a 
more in -depth and practical understanding of applying PartMaker’s Machining Function 
Windows for use with Live Tooling Operations.   
This document will explain the following: 
 

What types of Part Features Should be created in each Machining Function Face Window 
                                           Which Hole Group and Profile Groups Parameters options are available in each 

Machining Function Face Window 
Which Graphics Icons are available in each Machining Function Face Window 
How Part Features should be created in each Machining Function Face Window 

 
Many of the part examples provided in the pages to follow can be found in the various sub-
directories labeled with machine names in the Sample Directory found in the Pm-Swiss directory 
in which PartMaker SwissCAM is installed.  The file name and path for each file and specific 
*.job, *.tdb and *.cdb are provided where relevant for each example. 
 

Machining Function Selection 
CNC Swiss Machines are capable of performing a full set of turning operations: facing, turning, 
grooving and threading. Many CNC Swiss are also capable of performing various types of 
milling as well as drilling holes on different surfaces. Multiple spindles in which such operations 
can be performed simultaneously further increase the machines' productivity and complexity.  
 
Milling capabilities of a CNC Swiss lathe vary significantly and can include:  
 

Index milling/drilling 
Milling on a selected ZX plane 
Polar milling on the face of the part  
XZC continuous milling on cylindrical surfaces  
Milling interpolation in the YZ plane 

 
PartMaker CAM Software from IMCS, Inc. applies a Patented ‘divide and conquer’ 
programming strategy to simplify programming of Swiss Type Lathes. 
 
PartMaker helps you separate a complicated part surface into a manageable set of faces that 
may be either planar or rotational in nature. All features are represented by a surface relative to 
which a set of part features is referenced.  
 
On each face, a set of features may be machined using a variety of cutting tools. The software 
takes advantage of the Microsoft Windows operating system, which allows multiple windows to 
be displayed and accessed simultaneously.  
 



Chapter 2 

2-2 PartMaker  

A specific machining function such as turning, polar milling or cylindrical milling is assigned to 
each face. PartMaker lets you create a dedicated window that contains a workspace for the 
graphic representation of face features.  
 
A dialog box associated with each Face Window shows you the type of machining to be 
performed on a face, the location of the face boundaries and parameters defining the positioning 
of the face relative to the machine coordinate system.  

Getting Started: The Setup Dialog 
PartMaker employs a programming methodology whereby each machine motion type can be 
separated into a different window dedicated to a specific machining function. Every one of these 
windows is known as a Face Window. Once created, each Face Window can be accessed from 
the Window menu. 
 

 
 
 
Once divided into much smaller, similar motion components, programming of a multi-axis 
Swiss-type lathe becomes a much easier task. To best explain how PartMaker handles this task, 
it is necessary to first explain how each of these individual-machining functions is defined.  
 
Selection of the various machining functions is carried out in the Setup dialog. The Setup dialog 
can be accessed from the View menu or by clicking on the shortcut to the Setup dialog located 
in the upper left hand corner of your Face Window. On Startup, or when accessing the Setup 
dialog for the first time, you will see the following dialog. Some of the important components of 
this dialog are explained below: 
 
1. The Main Spindle and Sub Spindle radio buttons allow you to select whether the 

programming carried out in a particular Face Window is being machined on the Main or 
Sub-Spindle. 

 
2. The Tool Change X and Z positions for a particular machine should be entered here. 
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3. The Machining Function drop down menu allows you to select the type of machining 

motion being executed in a particular Face Window. The machining motions that can be 
defined in each selection from the Machining Function drop down menu are explained 
below.   

 
4. The List of Face Windows  displays the list of Face Windows  currently existing for a given 

job. 
 

5. The Rename To: field allows you to name the Face Window you are working with. Existing 
Face Windows  can be selected from the Window menu based on the names assigned to 
them in this field of the Setup dialog. 

 
6. Clicking the function buttons shown in the Setup dialog with the left-hand mouse button 

does the following: 
 

<Apply> Accepts or applies any new parameters or data entered 
into the various fields in the Setup dialog, and the dialog 
remains open. 

<New> Creates new face windows of different machining 
function types or on different spindles, adding to the List 
of Face Windows 

<Close> Accepts or applies any new parameters or data entered 
into the various fields in the Setup dialog, and closes the 
dialog. 

<Delete> Deletes the current selection from the List of Face 
Windows 

 
The various selections under the Machining Function drop down menu are explained on the 
following pages. 
 

          8.   The Notes fields allow the user to enter notes about a specific job. These notes can be 
   Directly output into the NC program to improve documentation. 
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Machining Function: Turning  
The Turn machining function uses conventional turning tools moving in the X and Z-axes. 
Motion is programmed using X and Z coordinates. This machining function includes on 
centerline drilling where a drill is held stationary while the spindle holding the part rotates. All 
drilled holes must therefore be on the rotational centerline of the part.    
 
The picture below shows the appearance of the Setup dialog when performing Turning on the 
Main Spindle.  
 

 
 

Length (L) Length of the finished part  

OD Starting outside diameter of bar stock before machining 

GB Length (l) 
Length of the “land area” of the guide bushing mechanism 
controlling the motion of the headstock through the main 
spindle 

ID Starting inside diameter of bar stock before machining  

Excess Stock (E) Rough stock left for facing on the front of the part  

GB Dia (d) Outside diameter of the guide bushing mechanism 
controlling the motion of the headstock through the main 
spindle 

Length (L) Length of the finished part  
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Machining Function: Mill XY Plane 
 

The Mill XY Plane machining function supports machining operations on the face of the part 
using the Y-axis capability of the machine. G-code output will be generated in the form of X and 
Y coordinates. Features that can be created by using this Face Window include off-center holes 
on the face of the part, pockets on the face of the part, and contours (such as CAM shapes) on the 
face of the part. 
 
Programming of this machining function requires that your Swiss-type lathe have a 
programmable Y-axis and that you have purchased the PartMaker Y-axis milling option. 
 

 
 
 

Length (L) Length of the finished part  

OD Starting outside diameter of bar stock before machining 

ID Starting inside diameter of bar stock before machining  
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Types of Features Created in Mill XY Machining Function Window 
 

The Mill XY window uses a Z-oriented “live” tool. There is no polar C-axis movement (the C-
axis indexes and locks).   
 
Note: Your machine must have y-axis capability and also needs to have ample travel to machine 
in the negative quadrant of the part. 
 
The features shown on the parts below are representative examples of features that can be 
created in the Mill XY Window.  The *.job, *.cdb and *.tdb files used to create some of these 
parts can be found on in the in the Samples directory which was installed when you initially 
installed PartMaker SwissCAM.  Where relevant, the locations of these files have been provided. 
  
                  

  
Figure 1: Milled Cam Figure 2.: Milled Cam  

(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Citizen_M\CitizenM.job, 
CitizenM.cdb, CitizenM.tdb) 

  

  
Figure 3: Off-Center Holes  
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Star_SV\StarSV.job, 
StarSV.cdb, StarSV.tdb) 

Figure 4: Milled Cam 
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Star_SV\StarSV.job, 
StarSV.cdb, StarSV.tdb) 
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Part Features Dialogs Available in Mill XY Machining Function 
              
Both the New Hole Group and New Profile Group commands from the Part Features  menu 
can be used in the Mill XY Machining Function Face Window.  
 
The Hole Group Parameters dialog will appear as shown below. Notice the orientation of the tool 
is in Z. 

 
 

 
 
 
 
 
 
 
 
 
 

 
 
 
 
 

 
 
 
 
 
 
 
 
 

 

Through Hole Check this box if you are drilling through the part  

Major Cycle Operation 
Indicates the major cycle operation as specified in the 
cycles database 

Diameter (d) Diameter of the tool, which is the major cycle operation. 

Chamfer(c) Specifies how much chamfer per side is needed 

Z_Surf (S) Establishes your Z-zero work plane 

Z_Rapid (R) Specifies how much clearance the tool will rapid to in 
front of your Z_Surf 

Inclination Angle Specifies the angle of the tool when making inclined holes 
(you must have a “B” axis or an angled attachment.) 

Nominal Depth (D) The depth of the operation to be performed 
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The Mill XY machining function can be used to create both Contours and Pockets.  Below, a 
Contour Mill cycle with Tool Position On centerline is shown.  To create a pocket, choose 
Pocket Mill from Cycle Type drop down menu. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

 

Cycle Type Indicates the type of feature to be milled, either a 
Contour Mill or Pocket Mill 

Tool Position 
For Contour Mill indicates the tool position during 
cutting, such as Left (climb milling), Right (conventional 
milling) or On (on centerline milling) 

Z_Surf (S) Establishes the Z-zero work plane i.e. a value 0 indicates 
the face of the part, a negative value indicates a Z-zero 
along the length of the part  

Z_Depth (D) The depth of the operation to be performed 

Z_Rapid (R) Specifies how much clearance the tool will rapid to in 
front of your Z_Surf. 

Bottom Finish (b) Amount of material left on the bottom of the feature for 
the finishing end mill to remove 

Wall Finish (w) Amount of material left on the side (or wall) of the feature 
for the finishing end mill to remove 

Roughing/Finishing Indicates whether a Roughing and/or Finishing Tool will 
be used 

Ramping Indicates the manner of entry of end mill into a feature, 
either Vertical, Helical, Sloped or Sloped Down and 
Return 



PartMaker Fundamentals 

User Guide 2-9 

Graphics Icons Available in the Mill XY Plane Machining Function 
 
The Mill XY Plane Machining Function Face Window uses the following icons to allow you to 
assign part features to created geometry in order to create a tool path. 
 

 
Single Hole Icon enables you to use Snap Modes to define the location on the geometry 
where a currently active Hole Group Symbol is to be executed. 

 
Chain Circle Icon enables you to click an enclosed circle on the geometry and specify 
that the currently active Hole Group Symbol is also to be automatically applied at the 
centers of all the other circles (holes) of the same size that appear on the geometry. 

 
Define Profile Icon  enables you to specify that the currently active group symbol is to 
be applied to the profile described by either coordinate entry or by clicking on geometric 
elements. 

 
Chain Geometry Icon enables you to specify that the currently active group symbol is 
to be applied to a profile that is created when PartMaker automatically connects all the 
elements that form an unbroken chain with an initial line or arc clicked. 

 
Engrave Icon enables you to use the Engrave Data dialog box to create a profile 
containing numbers and letters. 
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Programming Example using the Mill XY Plane Machining Function: 
Square and Off-Center Hole on Face 
 
A practical programming application of the Mill XY Plane machining function has been 
provided below.  This example assumes you have a knowledge of creating part geometry in the 
PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s Database and creating 
cycles in PartMaker’s Cycles Database. 
 
In the example given below, you will mill a ½ Inch Square with a ¼ inch End Mill and create a 
.1 diameter off-center hole. If you wish to complete this exercise on your own, make sure you 
have the following tools created in your PartMaker Tools Database (all tools used in the Mill XY 
Plane Face Window should have an orientation of Z Tool) 

1. .25 Inch Diameter End Mill 
2. .1 Inch Diameter Drill 
3. Spot Drill with a diameter larger than .1 inch 

Also make sure you have cycle in PartMaker’s Cycles Database created to include both a .1 
diameter drill and a spot drill. 

 
 

 
Step 1. Create a Mill XY Plane Machining Function Face Window 
 
Note: When creating a milled feature in PartMaker SwissCAM, you must always start with a 
turning operation.  Thus you must have a face window of machining function Turn created and 
at least one Turning part feature and tool path created (such as a facing operation). 
 
Start by creating a Mill XY Plane Machining Function Face Window.  To do so: 

1. Enter the Setup dialog by choosing Setup from the View menu or by clicking on the 
Setup dialog icon in the upper left hand corner of the screen 

2. In the Setup dialog, click the New button create a new Machining Function face 
Window 

3. From the Machining Function drop down menu, choose Mill XY Plane 
4. Enter the setup parameters as shown below: 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
Once the Setup dialog appears as above, click on Close 

 

Features to be created: 
 

1. Mill a .5 inch square with a 
.25 dia end mill 

2. Spot Drill and Drill an off 
center hole with a .1 
diameter drill 
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Step 2. Create Part Geometry 
 
Start by entering the CAD mode in the Mill XY Plane Window. Draw the following features: 

1. Choose Show Axes  from the View Menu 
2. Choose Show Boundaries  from the View Menu 
3. Draw a ½ inch square 
4. Draw a .05 inch radius circle with a center location at X<-.15> and Y<-.15> 

 
Your completed geometry and CAD Face Window should appear as shown below: 
 

 
 

Note: You can always go to a different Face Window in your *.job file by selecting from the 
Window menu.  Additionally, you can toggle between different Face Windows within the active 
Face Window by choosing Show Windows Icons  from the View menu and double clicking on 
the icon representing the Window you want to view. 
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Step 3. Create Part Features and assign tool paths 
 
Start by entering the CAM mode in the Mill XY Plane Window. First you will create the tool 
path to mill the square. To do so: 
 

1. From the Part Features  menu, choose New Profile Group 
2. Choose Contour Mill under Cycle Type 
3. Choose Left from Tool Position to indicate that climb milling will be performed 
4. Enter a Z_Depth of .5 
5. Enter a Tool Diameter of .25 and click Select Tools  
6. In the Cycle Name field, type Mill Square 

 
Your completed Profile Group Parameters dialog should appear as shown below: 

 

 
 

7. Assign the part feature to the square drawn earlier by clicking the Chain Geometry 
icon and clicking on the geometry to create the tool path.  It should appear as shown 
below: 
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8. From the Part Features menu, choose Verify Tool Path  to see the tool path as shown 
below: 

 
Choose Hide Work Tool Path to hide the tool path. 

 
Next, you will create the off-center hole. To do so: 
 

1. From the Part Features  menu, choose New Hole Group 
2. Uncheck the Through Hole Box 
3. Choose a Major Cycle Operation of Type: Drill 
4. Enter a Major Cycle Operation Diameter of .1 
5. Enter a Chamfer of .01 
6. Enter a Nominal Depth (D) of 0.5 
7. Click the Cycle button. 

 
Your completed Hole Group Parameters dialog should appear as shown below: 
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1. Assign the part feature to circle by clicking the Chain Circle icon and clicking on the 
circle representing the hole to create the tool path.  It should appear as shown below: 
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Machining Function: Mill ZY Plane  
 

The Mill ZY Plane machining function is used to perform milling interpolation in the ZY plane 
when the spindle is locked at a discreet angular position.  All motions are performed with a tool 
oriented along the machines X-axis.  
 
Programming of this machining function requires that your CNC Swiss-type lathe have a 
programmable Y-axis and that you have purchased the PartMaker Y-axis milling option. 
 

 
 

Angle (C)  Orientation angle of the stock to achieve the desired face 
position 

Length (L) Length of the finished part  

OD Starting outside diameter of bar stock before machining 

ID Starting inside diameter of bar stock before machining  
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Types of Features Created in Mill ZY Machining Function Window 
 

The Mill ZY window uses an X-oriented “live” tool. There is no polar c-axis movement (the c-
axis indexes and locks).  This window can be used for creating off-center cross-holes, flats on 
the diameter of the part and interpolated features. Saw Slots should also be created in this Face 
Window. 
 
The features shown on the parts below are representative exa mples of features that can be 
created in the Mill ZY Window.  The *.job, *.cdb and *.tdb files used to create some of these 
parts can be found on in the in the Sample directory which was installed when you initially 
installed PartMaker SwissCAM.  Where relevant, the locations of these files have been provided. 
 

 

   
Figure 1.: Milled Cylinder  
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Citizen_L\CitizenL-
Yaxis.job, CitizenL-Yaxis.cdb, CitizenL-
Yaxis.tdb) 

Figure 2.: Milled Flats  
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Citizen_L\CitizenL.job, 
CitizenL.cdb, CitizenL.tdb) 

  
Figure 3: Off-Center Cross Hole  
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Star_SV\StarSV.job, 
StarSV.cdb, StarSV.tdb) 

Figure 4: Milled slot 
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Part Features Dialogs Available in Mill ZY Machining Function 
              
Both the New Hole Group and New Profile Group commands from the Part  Features menu can 
be used in the Mill ZY Machining Function Face Window.  
 
The Hole Group Parameters dialog will appear as shown below. Notice the orientation of the tool 
is in X. 

     
 

                            
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Through Hole Check this box if you are drilling through the part  

Major Cycle Operation 
Indicates the major cycle operation as specified in the 
cycles database 

Diameter (d) Diameter of the tool, which is the major cycle operation. 

Chamfer(c) Specifies how much chamfer per side is needed 

X_Surf (S) Establishes your X-zero work plane on the OD of the part  

X_Rapid (R) Specifies how much clearance the tool will rapid above 
your X_Surf 

Nominal Depth (D) The depth of the operation to be performed 
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The Mill ZY machining function can be used to create both Contours and Pockets.  Below, a 
Contour Mill cycle with tool motion on centerline is shown.  Cutter compensation can also be used 
by choosing Left or Right from the Tool Position drop down menu. 

 

 

Cycle Type Indicates the type of feature to be milled, either 
a Contour Mill or Pocket Mill 

Tool Position 

For Contour Mill indicates the tool position 
during cutting, such as Left (climb milling), 
Right (conventional milling) or On (on 
centerline milling) 

X_Surf (S) Establishes the X-zero work plane, i.e. a value 
0.25 indicates the X-zero work plane is .25 
from the center of the part. 

X_Depth (D) The depth of the operation to be performed 

X_Rapid (R) Specifies how much clearance the tool will 
rapid to above of your X_Surf. 

Bottom Finish (b) Amount of material left on the bottom of the 
feature for the finishing end mill to remove 

Wall Finish (w) Amount of material left on the side (or wall) of 
the feature for the finishing end mill to remove 

Roughing/Finishing Indicates whether a Roughing and/or Finishing 
Tool will be used 

Ramping Indicates the manner of entry of end mill into a 
feature, either Vertical, Helical, Sloped or 
Sloped Down and Return 
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Graphics Icons – Machining Functions for Mill ZY Plane  
The Machining Functions Mill ZY Plane use some or all of the following icons to allow you to 
assign part features to created geometry in order to create a tool path. 
 

 
Single Hole Icon enables you to use Snap Modes to define the location on the geometry 
where a currently active Hole Group Symbol is to be executed. 

 
Chain Circle Icon enables you to click an enclosed circle on the geometry and specify 
that the currently active Hole Group Symbol is also to be automatically applied at the 
centers of all the other circles (holes) of the same size that appear on the geometry. 

 
Define Profile Icon  enables you to specify that the currently active group symbol is to 
be applied to the profile described by either coordinate entry or by clicking on geometric 
elements. 

 
Chain Geometry Icon enables you to specify that the currently active group symbol is 
to be applied to a profile that is created when PartMaker automatically connects all the 
elements that form an unbroken chain with an initial line or arc clicked. 

 
Engrave Icon enables you to use the Engrave Data dialog box to create a profile 
containing numbers and letters. 

   
Programming Example using the Mill ZY Plane Machining Function: 
 
Practical programming applications of the Mill ZY Plane machining function have been 
provided below.  This example assumes you have a knowledge of creating part geometry in the 
PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s Database and creating 
cycles in PartMaker’s Cycles Database. 
 

Example A: Creating a single flat with 2 off-center holes 

In the example given below, you will mill a flat with a ½ inch End Mill and create two .1 
diameter off-center holes. If you wish to complete this exercise on your own, make sure you 
have the following tools created in your PartMaker Tools Database (all tools used in the Mill ZY 
Plane Face Window should have an orientation of X Tool) 

1. .500 Inch Diameter End Mill 
2. .1 Diameter Drill 
3. Spot Drill with a diameter larger than .1 inch 
 

Also make sure you have a cycle in PartMaker’s Cycles Database created to include both a .1-
diameter drill and a spot drill. 

 
 

 
 
 
 

 

Features to be created: 
 

1. Mill a flat with a .500 dia 
end mill 

 
2. Spot Drill and Drill two off 

center holes with a .1 
diameter drill 
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Step 1. Create a Mill ZY Plane Machining Function Face Window 
 
Note: When creating a milled feature in PartMaker SwissCAM, you must always start with a 
turning operation.  Thus you must have a face window of machining function Turn created and 
at least one Turning part feature and tool path created (such as a facing operation). 
 
Start by creating a Mill ZY Plane Machining Function Face Window.  To do so: 

1. Enter the Setup dialog by choosing Setup from the View menu or by clicking on the 
Setup dialog icon in the upper left hand corner of the screen 

2. In the Setup dialog, click the New button create a new Machining Function face 
Window 

3. From the Machining Function drop down menu, choose Mill ZY Plane 
4. Enter the setup parameters as shown below: 
 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Once the Setup dialog appears as above, clic k on Close.   
 
Step 2. Create Part Geometry 
 
Start by entering the CAD mode in the Mill ZY Plane Window. Draw the following features: 

1. Choose Show Axes  from the View Menu 
2. Choose Show Boundaries  from the View Menu 
3. Draw one line at Z<. 5> to represent the end of the flat. 
4. Draw two .05-inch radius circles with a center location at Z<. 25> and Y<-.1875> and 

at Z<. 25> and Y <. 1875>. 
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Your completed geometry and CAD Face Window should appear as shown below: 
 

 
 

Note: You can always go to a different Face Window in your *.job file by selecting from the 
Window menu.  Additionally, you can toggle between different Face Windows within the active 
Face Window by choosing Show Windows Icons  from the View menu and double clicking on 
the icon representing the Window you want to view. 
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Step 3. Create Part Features and Assign Tool Paths 
 
Start by entering the CAM mode in the Mill ZY Plane Window. First you will create the tool 
path to mill the flat. To do so: 
 

1. From the Part Features  menu, choose New Profile Group 
2. Choose Contour Mill under Cycle Type 
3. Choose Left from Tool Position to indicate that climb milling will be performed 
4. Enter an X_Surf of .375 
5. Enter an X_Depth of .375 (we want the tool to go to center) 
6. Enter a Tool Diameter of .5 and click on Select Tools . 
7. In the Cycle Name field, type Mill Half. 

 
Your completed Profile Group Parameters dialog should appear as shown below: 

 

 
 

8. Assign the part feature to the flat drawn earlier by clicking the Chain Geometry icon 
and clicking on the geometry to create the tool path.  It should appear as shown below: 
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9. From the Part Features menu, choose Verify Tool Path  to see the tool path as shown 
below: 

 
Choose Hide Work Tool Path to hide the tool path. 

 
Next, you will create the off-center holes. To do so: 
 

1. From the Part Features  menu, choose New Hole Group 
2. Uncheck the Through Hole Box 
3. Choose a Major Cycle Operation of Type: Drill 
4. Enter a Major Cycle Operation Diameter of .1 
5. Enter a Chamfer of .01 
6. Enter a Nominal Depth (D) of 0.2 
7. Click the Cycle button. 

 
Your completed Hole Group Parameters dialog should appear as shown below: 
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1. Assign the part feature to the circles by clicking the Chain Circle icon and clicking on 
the circle representing the holes to create the tool path.  It should appear as shown 
below: 

 

 
 

Example B: Creating a Saw Slot 
 
In the example given below, you will mill a .050 wide slot with a 1-inch Diameter Slot Mill. If 
you wish to complete this exercise on your own, make sure you have the following tools created 
in your PartMaker Tools Database (all tools used in the Mill ZY Plane Window should have an 
orientation of X Tool) 
 
Note: You will have needed to purchase the advanced tools option to create a Slotting Saw in 

your tools directory. 
 

1. 1 Inch Diameter Slot Mill 
 

 

 
 

Features to be created: 
 

 Mill a .125 thick slot x ¼ deep 
along the face of the part.  
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Step 1. Create a Mill ZY Plane Machining Function Face Window 
 
Note: When creating a milled feature in PartMaker SwissCAM, you must always start with a 
turning operation.  Thus you must have a face window of machining function Turn created and 
at least one Turning part feature and tool path created (such as a facing operation). 
 
Start by creating a Mill ZY Plane Machining Function Face Window.  To do so: 

1. Enter the Setup dialog by choosing Setup from the View menu or by clicking on the 
Setup dialog icon in the upper left hand corner of the screen 

2. In the Setup dialog, click the New button to create a new Machining Function face 
Window 

3. From the Machining Function drop down menu, choose Mill ZY Plane 
4. Enter the setup parameters as shown below: 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Once the Setup dialog appears as above, click on Close 
 
Step 2. Create Part Geometry 
 
Start by entering the CAD mode in the Mill ZY Plane Window. Draw the following features: 

1. Choose Show Axes  from the View Menu 
2. Choose Show Boundaries  from the View Menu 
3. Draw a line that represents the .250 depth in Z for the end of the mill slot. 
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Your completed geometry and CAD Face Window should appear as shown below: 
 

 
 

Note: You can always go to a different Face Window in your *.job file by selecting from the 
Window menu.  Additionally, you can toggle between different Face Windows within the active 
Face Window by choosing Show Windows Icons  from the View menu and double clicking on 
the icon representing the Window you want to view. 
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Step 3. Create Part Features and assign tool paths 
 
Start by entering the CAM mode in the Mill ZY Plane Window. First you will create the tool 
path to mill the square. To do so: 
 

1. From the Part Features  menu, choose New Profile Group 
2. Choose Contour Mill under Cycle Type 
3. Choose Left from Tool Position to indicate that climb milling will be performed 
4. Enter an X_Depth of .4375 (X_Surf + ½ thickness of the Slotting Saw.) 
5. Enter the Tool ID number of the Slotting Saw in the Tool ID box and then hit Apply. 
6. In the Cycle Name field, type Slotting Saw. 
7. Click on the Close Button 

 
Your completed Profile Group Parameters dialog should appear as shown below: 

 

 
 

8. Assign the part feature to the square drawn earlier by clicking the Chain Geometry 
icon and clicking on the geometry to create the tool path.  It should appear as shown 
below: 
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9. From the Part Features menu, choose Verify Tool Path  to see the tool path as shown 
below: 

 
Choose Hide Work Tool Path to hide the tool path. 
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Machining Function: Mill ZX Plane 
 

The Mill ZX Plane machining function is used to perform milling in the Z and X planes only. 
Such operations typically involve following a turning profile with an end mill (often ball nose) 
with the machine spindle in a locked position.  
 
Programming of this machining function requires that your CNC Swiss-type lathe have a 
programmable Y-axis and that you have purchased the PartMaker Y-axis milling option. 
 

 
 

Angle (C)  Orientation angle of the stock to achieve the desired face 
position 

Y-coord (p) Y coordinate value measuring the distance from the 
centerline of the part the tool is offset during machining.  
This value should always be positive. 

Length (L) Length of the finished part  

OD Starting outside diameter of bar stock before machining 

ID Starting inside diameter of bar stock before machining  
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Types of Features Created in Mill ZX Machining Function Window 
 

The Mill ZX window uses an X-oriented “live” tool. There is no polar c-axis movement (the C-
axis indexes and locks).  This window is mainly used for doing key slots and operations that 
require simultaneous Z-axis and X-axis moves. 
 
The features shown on the parts below are representative examples of features that can be 
created in the Mill ZX Window. 
 

 
 
 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 

 

  
Figure 1.  Milled Slot 

 
Figure 1a. (Cross section of milled slot) 

  

 
Figure 2. Milled slot 

 
Figure2a. (Cross section of milled slot) 
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Part Features Dialogs Available in Mill ZX Machining Function 
 

The Mill ZX machining function can be used to create Contours only.  Below, a Contour Mill 
cycle with tool motion on centerline is shown.  Cutter compensation can also be used by 
choosing Left or Right from the Tool Position drop down menu. 
 
Note: In the Mill ZX window you are only allowed to use a New Profile Group. A New Hole 
group and Pocket Milling are not accessible. 

 

 

 

 

 

 
 
Graphics Icons – Machining Function Mill ZX Plane 
The Machining Function Mill ZX Plane uses the following icons to allow you to assign part 
features to created geometry in order to create a tool path. 

 
Single Hole Icon Not applicable 

 

Profile Icon enables you to specify that the currently active group symbol is to be 
applied to the profile described by either coordinate entry or by clicking on geometric 
elements.  

 
Chain Icon enables you to specify that the currently active group symbol is to be 
applied to a profile that is created when PartMaker automatically connects all the 

elements that form an unbroken chain with an initial line or arc clicked. 
 

Cycle Type Indicates the type of feature to be milled. In the Mill ZX Face 
Window this must always be set to Contour Mill. 

Tool Position 
For Contour Mill indicates the tool position during cutting, such as 
Left (climb milling), Right (conventional milling) or On (on 
centerline milling). 

X_Surf (S) Establishes the X-zero work plane, i.e. a value 0.25 indicates the X-
zero work plane is .25 from the center of the part. 

X_Rapid (R) Specifies how much clearance the tool will rapid above your X_Surf 
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Programming Example using the Mill ZX Plane Machining Function: 
 
A practical programming application of the Mill ZX Plane machining function has been 
provided below.  This example assumes you have a knowledge of creating part geometry in the 
PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s Database and creating 
cycles in PartMaker’s Cycles Database. 
 
In the example given below, you will mill a .125 wide slot down the length of the part and radius 
out. If you wish to complete this exercise on your own, make sure you have the following tools 
created in your PartMaker Tools Database (all tools used in the Mill ZX Plane Face Window 
should have an orientation of X Tool) 
 

1. .125 Inch Diameter End Mill 
 

 

 
Step 1. Create a Mill ZX Plane Machining Function Face Window 
 
Note: When creating a milled feature in PartMaker SwissCAM, you must always start with a 
turning operation.  Thus you must have a face window of machining function Turn created and 
at least one Turning part feature and tool path created (such as a facing operation). 
 
Start by creating a Mill ZX Plane Machining Function Face Window.  To do so: 

1. Enter the Setup dialog by choosing Setup from the View menu or by clicking on the 
Setup dialog icon in the upper left hand corner of the screen 

2. In the Setup dialog, click the New button to create a new Machining Function face 
Window 

3. From the Machining Function drop down menu, choose Mill ZX Plane 
4. Enter the setup parameters as shown below: 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

 

Features to be created: 
 

Slot running down the length of 
the part then radius out in X. 

 



PartMaker Fundamentals 

User Guide 2-33 

Step 2. Create Part Geometry 
 
Start by entering the CAD mode in the Mill ZX Plane Window. Draw the following features: 

1. Choose Show Axes  from the View Menu 
2. Choose Show Boundaries  from the View Menu 
3. Draw a horizontal line down the center of the part. Draw a vertical line 1 inch parallel 

to the face of the part. 
4. Choose the Fillet Icon and enter a value of .2 and click on the inside of the 

intersection you just created to generate a radius. 
 
Your completed geometry and CAD Face Window should appear as shown below: 
 

 
 

Note: You can always go to a different Face Window in your *.job file by selecting from the 
Window menu.  Additionally, you can toggle between different Face Windows within the active 
face Window by choosing Show Windows Icons  from the View menu and double clicking on 
the icon representing the Window you want to view. 
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Step 3. Create Part Features and assign tool paths 
 
Start by entering the CAM mode in the Mill ZX Plane Window. First you will create the tool 
path to mill the slot. To do so: 
 

1. From the Part Features  menu, choose New Profile Group 
2. Choose Contour Mill under Cycle Type 
3. Choose On from Tool Position to indicate that we will be milling with the centerline 

of the tool. 
4. Enter a Z_Surf of 0.3125 
5. Enter a Tool Diameter of 0.125 and click Select Tools  
6. In the Cycle Name field, type Mill Slot 

 
Your completed Profile Group Parameters dialog should appear as shown below: 

 

 
 

7. Assign the part feature to the square drawn earlier by clicking the Chain Geometry 
icon and clicking on the geometry to create the tool path.  It should appear as shown 
below: 

 

 



PartMaker Fundamentals 

User Guide 2-35 

8. From the Part Features menu, choose Verify Tool Path  to see the tool path as shown 
below: 

 
Choose Hide Work Tool Path to hide the tool path. 
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Machining Function: Mill Polygon  
 

The Mill Polygon machining function allows you to create polygon shapes on the OD of a part 
using the Y-axis capability of your machine and a tool oriented along the X-axis of the machine. 
 
Programming of this machining function requires that your CNC Swiss-type lathe have a 
programmable Y-axis and that you have purchased the PartMaker Y-axis milling option. 
 
 

 
 

Length (L) Length of the finished part  

OD Starting outside diameter of bar stock before machining 

ID Starting inside diameter of bar stock before machining  
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Types of Features Created in Mill Polygon Machining Function Window 
 

The Mill Polygon window uses an X-oriented “live” tool. There is no polar C-axis movement 
(the C-axis indexes and locks).  This window is mainly used when creating multiple flats like a 
polygon, square or a hex. This operation does use bi-directional cutting therefore it cuts in one 
direction and indexes then cut in the opposite direction.  
 
The features shown on the parts below are representative examples of features that can be 
created in the Mill Polygon Window.  The *.job, *.cdb and *.tdb files used to create some of 
these parts can be found on in the in the Sample directory which was installed when you initially 
installed PartMaker SwissCAM.  Where relevant, the locations of these files have been provided. 

 

  
Figure 1.: Milled Hex 
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Citizen_L\CitizenL.job, 
CitizenL.cdb, CitizenL.tdb) 

Figure 2.: Milled square  
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Citizen_L\CitizenL-Yaxis.job, 
CitizenL-Yaxis.cdb, CitizenL-Yaxis.tdb) 

  
Figure 3.: Milled Hex  
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Citizen_L\Citizen_L_Swiss.job, 
 Citizen_L_Swiss.cdb, Citizen_L_Swiss.tdb) 

Figure 4.: Milled Polygon  
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Hardinge ST\Hardinge-
Caxis.job, Hardinge-Caxis.cdb, Hardinge-
Caxis.tdb) 
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Part Features Dialogs Available in Mill Polygon Machining Function 
 

The Mill Polygon machining function can be used to create flats only.  Below, a Profile Group 
parameter window is shown. In the drop down menu you pick the tool edge you are going to use 
with respect to the part.   

 
Note: In the Mill Polygon window you are only allowed to use New Profile Group. A New Hole 
Group is not accessible. 

 
 

 
 
 
 
 
 
 
 
 
 

 

 
 

 

Graphics Icons – Machining Function Mill Polygon 
The machining functions for Mill Polygon uses the following icons to allow you to assign part 
features to created geometry in order to create a tool path. 
  

  
Define Profile Icon  enables you to specify that the currently active group symbol is to 
be applied to the profile described by either coordinate entry or by clicking on geometric 
elements. 

 

 

Chain Geometry Icon enables you to specify that the currently active group symbol is 
to be applied to a profile that is created when PartMaker automatically connects all the 
elements that form an unbroken chain with an initial line or arc clicked. 

Distance From Part 
Face, To: 

Indicates placement of tool with respect to the part face.  The tool 
can be positioned with respect to the Left Tool Edge (P1), the Tool 
Center (P2) or the Right Tool Edge (P3).   

X_Surf (S) Establishes the X-zero work plane, i.e. a value 0.25 indicates the X-
zero work plane is .25 from the center of the part. 

X_Rapid (R) Specifies how much clearance the tool will rapid above your X_Surf 

Clearance(C) Specifies the clearance amount the tool will position to past the 
barstock diameter. 
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Programming Example using the Mill Polygon Machining Function: 
Milling a Hexagon 
 
A practical programming application of the Mill Polygon Plane machining function has been 
provided below.  This example assumes you have a knowledge of creating part geometry in the 
PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s Database. 
 
In the example given below, you will mill a hexagon with a ¼ inch End Mill. If you wish to 
complete this exercise on your own, make sure you have the following tools created in your 
PartMaker Tools Database (all tools used in the Mill Polygon Face Window should have an 
orientation of X Tool) 
 

1. .25 Inch Diameter End Mill 
 

 

 
Step 1. Create a Mill Polygon Plane Machining Function Face Window 
 
Note: When creating a milled feature in PartMaker Swis sCAM, you must always start with a 
turning operation.  Thus you must have a face window of machining function Turn created and 
at least one Turning part feature and tool path created (such as a facing operation). 
 
Start by creating a Mill Polygon Plane Machining Function Face Window.  To do so: 

1. Enter the Setup dialog by choosing Setup from the View menu or by clicking on the 
Setup dialog icon in the upper left hand corner of the screen 

2. In the Setup dialog, click the New button create a new Machining Function face 
Window 

3. From the Machining Function drop down menu, choose Mill Polygon  
4. Enter the setup parameters as shown below: 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
Once the Setup dialog appears as above, click on Close 

 

Features to be created: 
 
Mill a hexagon with a .25 dia end 
mill 
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Step 2. Create Part Geometry 
 
Start by entering the CAD mo de in the Mill Polygon Window. Draw the following features: 

1. Choose Show Axes  from the View Menu 
2. Choose Show Boundaries  from the View Menu 
3. Choose the Hexagon Icon and enter .25 for the Flat to Flat Distance 

 
Your completed geometry and CAD Face Window should appear as shown below: 
 

 
 

Note: You can always go to a different Face Window in your *.job file by selecting from the 
Window menu.  Additionally, you can toggle between different Face Windows within the active 
face Window by choosing Show Windows Icons  from the View menu and double clicking on 
the icon representing the Window you want to view. 
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Step 3. Create Part Features and assign tool paths 
 
Start by entering the CAM mode in the Mill Polygon Window. First you will create the tool path 
to mill the hexagon. To do so: 
 

1. From the Part Features  menu, choose New Profile Group 
2. Choose Left Tool Edge (P1) under Distance From Part Face 
3. Enter 0.2 For the P1 value 
4. Enter a Tool Diameter of .25 and click Select Tools  
5. In the Cycle Name field, type Mill Polygon 

 
Your completed Profile Group Parameters dialog should appear as shown below: 

 

 
 

6. Assign the part feature to the square drawn earlier by clicking the Chain Geometry 
icon and clicking on the geometry to create the tool path.  It should appear as shown 
below: 

 

 
 



Chapter 2 

2-42 PartMaker  

7. From the Part Features menu, choose Verify Tool Path  to see the tool path as shown 
below: 

 
Choose Hide Work Tool Path to hide the tool path. 
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Machining Function: Mill End, Index  
 
The Mill End, Index machining functon is used when drilling holes and milling slots on the end 
face of the part. The holes are located in the XY plane and oriented along the Z-axis.  
 
The shapes that can be created with this machining function are:  
 

??Holes in the end of the work created by Z-axis feed. This motion type supports off-center 
drilling on the end of the part, using C-axis indexing and X-axis positioning to locate the 
hole position.  

 
??Radial slots which are milled using C-axis indexing to position and hold the part while X-

axis motion is used to cut the part. The tool would be a milling tool oriented along the Z-
axis. 

 

 
 

Length (L) Length of the finished part  

OD Starting outside diameter of bar stock before machining 

ID Starting inside diameter of bar stock before machining  
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Types of Features Created in Mill End Index Machining Function Window 
 

The MILL END INDEX window uses a Z-oriented “live” tool. There is no polar c-axis 
movement (the C-axis indexes and locks).  This window is mainly used for doing any number of 
holes or slots using a Z-oriented tool.  
 
The features shown on the parts below are representative examples of features that can be 
created in the MILL END INDEX window 

                              

 

 

 

 

 
  

Figure 1. Face holes Figure 2. Face holes and Slots 
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Part Features Dialogs Available in Mill End Index Machining Function 
              
Both the New Hole Group and New Profile Group commands from the Part Features menu 
can be used in the Mill End Inde x Machining Function Face Window.  
 
The Hole Group Parameters dialog will appear as shown below. Notice the orientation of the tool 
is in Z. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 

Z_Surf (S) 
Establishes your Z-zero work plane 
 

Z_Rapid (R) 
Specifies how much clearance the tool will rapid to in 
front of your Z_Surf 

Inclination Angle 
Specifies the angle of the tool when making inclined holes 
(you must have a “B” axis or an angled attachment.) 

Nominal Depth (D) The depth of the operation to be performed 

 
 
 

Through Hole Check this box if you are drilling through the part  

Major Cycle Operation 
Indicates the major cycle operation as specified in the 
cycle’s database 

Diameter (d) Diameter of the tool, which is the major cycle operation 

Chamfer(c) Specifies how much chamfer per side is needed 
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The Mill End Index machining function can be used to create Contours only.  Below, a Contour 
Mill cycle with tool motion on centerline is shown.   

 
 

 

Cycle Type Indicates the type of feature to be milled is a 
Contour Mill  

Tool Position 
For Contour Mill indicates the tool position 
during cutting, On (on centerline milling) 

Z_Surf (S) Establishes the Z-zero work plane i.e. a value 0 
indicates the face of the part, a negative value 
indicates a Z-zero along the length of the part  

Z_Depth (D) The depth of the operation to be performed 

Z_Rapid (R) Specifies how much clearance the tool will 
rapid to in front of your Z_Surf. 

Bottom Finish (b) Amount of material left on the bottom of the 
feature for the finishing end mill to remove 

Roughing/Fi nishing Indicates whether a Roughing and/or Finishing 
Tool will be used 

Ramping Does not apply to the Mill End Index 
machining function 
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Graphics Icons – Machining Functions Mill End Index  
The Machining Functions Mill End Index uses the following icons to allow you to assign part 
features to created geometry in order to create a tool path. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Single Hole Icon enables you to use Snap Modes to define the location on the geometry 
where a currently Hole Group Symbol is to be executed. 

 
Chain Circle Icon enables you to click an enclosed circle on the geometry and specify 
that the currently active Hole Group Symbol is also to be automatically applied at the 
centers of all the other circles (holes) of the same size that appear on the geometry. 

 
Profile Icon enables you to specify that the currently active group symbol is to be 
applied to the profile described by either coordinate entry or by clicking on geometric 
elements.  When performing indexing operations, the Profile Icon may only join two 
points during its usage. 

 
Chain Icon enables you to specify that the currently active group symbol is to be applied 
to a profile that is created when PartMaker automatically connects all the elements that 
form an unbroken chain with an initial line or arc clicked. When performing indexing 

operations, the Chain Icon may only join two points during its usage. 
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Programming Example using the Mill End Index Machining Function: Bolt 
Hole Pattern on the Face 
 
A practical programming application of the Mill End Index machining function has been 
provided below.  This example assumes you have a knowledge of creating part geometry in the 
PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s Database and creating 
cycles in PartMaker’s Cycles Database. 
 
In the example given below, you will drill  six .125 diameter holes on the face of the part. If you 
wish to complete this exercise on your own, make sure you have the following tools created in 
your PartMaker Tools Database (all tools used in the Mill End Index Face Window should have 
an orientation of Z Tool) 

1. .125 Inch Diameter Drill 
2. Spot Drill with a diameter larger than .125 inch 

Also make sure you have cycle in PartMaker’s Cycles Database created to include both a .125-
inch drill and a spot drill. 

 
 

 
Step 1. Create a Mill End Index Machining Function Face Window 
 
Note: When creating a milled feature in PartMaker SwissCAM, you must always start with a 
turning operation.  Thus you must have a face window of machining function Turn created and 
at least one Turning part feature and tool path created (such as a facing operation). 
 
Start by creating a Mill End Index Machining Function Face Window.  To do so: 

1. Enter the Setup dialog by choosing Setup from the View menu or by clicking on the 
Setup dialog icon in the upper left hand corner of the screen 

2. In the Setup dialog, click the New button create a new Machining Function face 
Window 

3. From the Machining Function drop down menu, choose Mill End Index 

 

Features to be created: 
 
Spot Drill and Drill (6) holes with a 
.125 diameter drill 
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4. Enter the setup parameters as shown below: 
 

 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Once the Setup dialog appears as above, click on Close 
 
Step 2. Create Part Geometry 
 
Start by entering the CAD mode in the Mill End Index Window. Draw the following features: 

1. Choose Show Axes  from the View Menu 
2. Choose Show Boundaries  from the View Menu 
3. Draw a .0625 inch radius circle with a center location at X<-.2> and Y<0> 
4. Choose the Rotate command and make 5 copies and rotate about the X<0> and Y<0>. 

 
Your completed geometry and CAD Face Window should appear as shown below: 
 

 
 

Note: You can always go to a different Face Window in your *.job file by selecting from the 
Window menu.  Additionally, you can toggle between different Face Windows within the active 
face Window by choosing Show Windows Icons  from the View menu and double clicking on 
the icon representing the Window you want to view. 
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Step 3. Create Part Features and assign tool paths 
 
Start by entering the CAM mode in the Mill End Index Window. First you will create the tool 
path to mill the square. To do so: 
 
Next, you will create the 0.125 Boltholes, to do so: 
 

1. From the Part Features  menu, choose New Hole Group 
2. Uncheck the Through Hole Box 
3. Choose a Major Cycle Operation of Type: Drill 
4. Enter a Major Cycle Operation Diameter of .125 
5. Enter a Chamfer of .01 
6. Enter a Nominal Depth (D) of 0.450 
7. Click the Cycle button. 

 
Your completed Hole Group Parameters dialog should appear as shown below: 

 

 
 

8. Assign the part feature to circle by clicking the Chain Circle icon and clicking on the 
circle representing the hole to create the tool path.  It should appear as shown below: 
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Machining Function: Mill Diam, Index  
 
The Mill Diam, Index machining function allows you  to create “cross holes” or radial slots on 
the OD of the part.  In order to support this machining function, your CNC Swiss-type lathe must 
be able to support C-axis indexing, which may not be performed while the tool is in contact with 
the work.  
 
This  machining function supports the following features cut on the outside diameter of the work 
using a tool oriented along the machine's X-axis:  
 

?? Slots oriented along the length (Z-axis) of the stock. 
?? Holes drilled anywhere along the cylinder except the end of the stock. 

 

 
 

Length (L) Length of the finished part  

OD Starting outside diameter of bar stock before machining 

ID Starting inside diameter of bar stock before machining  
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Types of Features Created in Mill Diam Index Machining Function Window 
 

The Mill Diam Index window uses a X-oriented “live” tool. There is no polar c-axis movement 
(the c-axis indexes and locks).  This window is mainly used for doing any number of holes or 
slots using a X-oriented tool.  
 
The features shown on the parts below are representative examples of features that can be 
created in the Mill Diam Index window.   

 
 

  
Figure 1.  Cross holes  Figure 2. Cross slots  
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Part Features Dialogs Available in Mill Diam Index Machining Function 
              
Both the New Hole Group and New Profile Group commands from the Part Features menu 
can be used in the Mill Diam Index Machining Function Face Window.  
 
The Hole Group Parameters dialog will appear as shown below. Notice the orientation of the tool 
is in X. 

 
 

 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

 

Through Hole Check this box if you are drilling through the part  

Major Cycle Operation 
Indicates the major cycle operation as specified in the 
cycle’s database. 

Diameter (d) Diameter of the tool, which is the major cycle operation. 

Chamfer(c) Specifies how much chamfer per side is needed 

X_Surf (S) 
Establishes your X-zero work plane. 
 
 

X_Rapid (R) 
Specifies how much clearance the tool will rapid to in 
front of your X_Surf. 
 

Nominal Depth (D) The depth of the operation to be performed 
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 The Mill Diam,Index machining function can be used to create Contours only.  Below, a Contour 
Mill cycle with tool motion on centerline is shown.   

 

 

Cycle Type Indicates the type of feature to be milled is a 
Contour Mill  

Tool Position 
For Contour Mill indicates the tool position 
during cutting, On (on centerline milling) 

X_Surf (S) Establishes the X-zero work plane, i.e. a value 
0.25 indicates the X-zero work plane is .25 
from the center of the part. 

X_Depth (D) The depth of the operation to be performed 

X_Rapid (R) Specifies how much clearance the tool will 
rapid to above your X_Surf. 

Bottom Finish (b) Amount of material left on the bottom of the 
feature for the finishing end mill to remove 

Roughing/Finishing Indicates whether a Roughing and/or Finishing 
Tool will be used 

Ramping Does not apply to the Mill Diam, Index 
machining function 
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Graphics Icons – Machining Functions for Mill Diam, Index 
The Machining Functions for Mill Diam, Index uses the following icons to allow you to assign 
part features to created geometry in order to create a tool path. 
 

 
Single Hole Icon enables you to use Snap Modes to define the location on the geometry 
where a currently Hole Group Symbol is to be executed. 

 
Chain Circle Icon enables you to click an enclosed circle on the geometry and specify 
that the currently active Hole Group Symbol is also to be automatically applied at the 
centers of all the other circles (holes) of the same size that appear on the geometry. 

 
Profile Icon enables you to specify that the currently active group symbol is to be 
applied to the profile described by either coordinate entry or by clicking on geometric 
elements.  When performing indexing operations, the Profile Icon may only join two 
points during its usage. 

 
Chain Icon enables you to specify that the currently active group symbol is to be applied 
to a profile that is created when PartMaker automatically connects all the elements that 
form an unbroken chain with an initial line or arc clicked. When performing indexing 

operations, the Chain Icon may only join two points during its usage. 
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Programming Example using the Mill Diameter Index Machining Function: 
Creating Cross holes 
 
A practical programming application of the Mill Diameter Index machining function has been 
provided below.  This example assumes you have a knowledge of creating part geometry in the 
PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s Database and creating 
cycles in PartMaker’s Cycles Database. 
 
In the example given below, you will Drill six holes with a .125 diameter drill. If you wish to 
complete this exercise on your own, make sure you have the following tools created in your 
PartMaker Tools Database (all tools used in the Mill Diameter Index Face Window should have 
an orientation of X Tool). 

1. .125 Inch Diameter Drill 
2. Spot Drill with a diameter larger than .125 inch 

Also make sure you have cycle in PartMaker’s Cycles Database created to include both a .125-
inch drill and a spot dril l. 

 
 

 
Step 1. Create a Mill Diameter Index Machining Function Face Window 
 
Note: When creating a milled feature in PartMaker SwissCAM, you must always start with a 
turning operation.  Thus you must have a face window of machining function Turn created and 
at least one Turning part feature and tool path created (such as a facing operation). 
 
Start by creating a Mill Diam, Index Machining Function Face Window.  To do so: 

1. Enter the Setup dialog by choosing Setup from the View menu or by clicking on the 
Setup dialog icon in the upper left hand corner of the screen 

2. In the Setup dialog, click the New button create a new Machining Function face 
Window 

3. From the Machining Function drop down menu, choose Mill Diam, Index 
4. Enter the setup parameters as shown below: 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 

 

Features to be created: 
 
Spot Drill and Drill six holes on 
diameter with a .125 diameter drill 
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Step 2. Create Part Geometry 
 
Start by entering the CAD mode in the Mill Diam, Index Window. Draw the following features: 

1. Choose Show Axes  from the View Menu 
2. Choose Show Boundaries  from the View Menu 
3. Draw a .0625-inch radius circle with a center location at Z<. 25. > and C<0>. 
4. Click on the Selection Icon  and click on the circle you just created. 
5. Choose Translate  from the Edit Menu and make 5 more copies, Z distance is 0 and C 

Distance of 60 degrees. 
 

Your completed geometry and CAD Face Window should appear as shown below: 
 

 
 

Note: You can always go to a different Face Window in your *.job file by selecting from the 
Window menu.  Additionally, you can toggle between different Face Windows within the active 
Face Window by choosing Show Windows Icons  from the View menu and double clicking on 
the icon representing the Window you want to view. 
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Step 3. Create Part Features and assign tool paths 
 
Start by entering the CAM mode in the Mill Diam, Index Window. First you will create the tool 
path to drill the cross holes. To do so: 

 
1. From the Part Features  menu, choose New Hole Group 
2. Uncheck the Through Hole Box 
3. Choose a Major Cycle Operation of Type: Drill 
4. Enter a Major Cycle Operation Diameter of .125 
5. Enter a Chamfer of .01 
6. Enter a Nominal Depth (D) of 0.3125 
7. Click the Cycle button. 

 
Your completed Hole Group Parameters dialog should appear as shown below: 

 

 
 
 

8. Assign the part feature to circle by clicking the Chain Circle icon and clicking on the 
circles representing the holes to create the tool path.  It should appear as shown below: 
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Machining Function: Mill End, Polar  
 

The Mill End, Polar machining function allows you to perform polar interpolation on the face of 
the part. This machining function assumes that the CNC Swiss-type lathe has the ability to 
perform simultaneous feed motions with the X, Z and C-axes.  
 
The following rules apply to Mill End, Polar:  
 
?? Tools must be oriented along the machine’s Z-axis.  
 
?? Shapes created must not pass, or if extended, pass through the center of rotation of the stock 

(X=0). For example, the radial slots that are programmable in Mill End, Index may NOT be 
programmed using Mill End, Polar. Also, any arc move that intersects the X=0 center is 
NOT allowed to be programmed using this machining function. 

 
Programming of this machining function requires that your CNC Swiss-type lathe has a 
programmable C-axis and that you have purchased the PartMaker C-axis milling option. 
 

 
 

Length (L) Length of the finished part  

OD Starting outside diameter of bar stock before machining 

ID Starting inside diameter of bar stock before machining  
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Types of Features Created in Mill End Polar Machining Function Window 
 

The MILL END POLAR window uses a Z-oriented “live” tool. There is polar C-Axis movement 
(the C-Axis does not lock).  This window is mainly used for milling profiles and pockets on the 
face of the part. 
 
The features shown on the parts below are representative examples of features that can be 
created in the MILL END POLAR window.  The *.job, *.cdb and *.tdb files used to create some 
of these parts can be found on in the in the Sample directory which was installed when you 
initially installed PartMaker SwissCAM.  Where relevant, the locations of these files have been 
provided. 

 
 
 
 

  
Figure 1. Milled slot 
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Star_SV\StarSV.job, 
StarSV.cdb, StarSV.tdb) 

 

Figure 2. Milled Cam 
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Citizen_M\CitizenM.job, 
CitizenM.cdb, CitizenM.tdb) 
 

  
Figure 3. Milled Cam 
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Hardinge_ST\Hardinge-
Caxis.job, Hardinge-Caxis.cdb, Hardinge-
Caxis.tdb) 
 

Figure 4. Milled Pocket on the face 
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Part Features Dialogs Available in Mill End Polar Machining Function 
 

The Mill End Polar machining function can be used to create both Contours and Pockets.  
Below, a Contour Mill cycle with tool motion on centerline is shown. If you wish to create a 
pocket, choose Pocket Mill from Cycle Type drop down menu.  Cutter compensation can also be 
used by choosing Left or Right  from the Tool Position drop down menu. 

 
           Note: In the Mill End Polar window you are only allowed to use a New Profile Group. New 

Hole group is not accessible 
 

 

 
 

Cycle Type Indicates the type of feature to be milled, either a 
Contour Mill or Pocket Mill 

Tool Position 
For Contour Mill indicates the tool position during 
cutting, such as Left (climb milling), Right 
(conventional milling) or On (on centerline milling) 

Z_Surf (S) Establishes the Z-zero work plane i.e. a value 0 
indicates the face of the part, a negative value 
indicates a Z-zero along the length of the part  

Z_Depth (D) The depth of the operation to be performed 

Z_Rapid (R) Specifies how much clearance the tool will rapid to 
in front of your Z_Surf. 

Bottom Finish (b) Amount of material left on the bottom of the feature 
for the finishing end mill to remove 

Wall Finish (w) Amount of material left on the side (or wall) of the 
feature for the finishing end mill to remove 

Roughing/Finishing Indicates whether a Roughing and/or Finishing Tool 
will be used 

Ramping Indicates the manner of entry of end mill into a 
feature, either Vertical, Helical, Sloped or Sloped 
Down and Return 
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Graphics Icons Available in the Mill End Polar Machining Function 
 

    The Machining Functions Mill End Polar, uses the following icons to allow you to assign part 
features to created geometry in order to create a tool path. 

 

 
Define Profile Icon  enables you to specify that the currently active group symbol is to 
be applied to the profile described by either coordinate entry or by clicking on geometric 
elements. 

 
Chain Geometry Icon enables you to specify that the currently active group symbol is 
to be applied to a profile that is created when PartMaker automatically connects all the 
elements that form an unbroken chain with an initial line or arc clicked. 

 
Engrave Icon enables you to use the Engrave Data dialog box to create a profile 
containing numbers and letters. 
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Programming Example using the Mill End Polar Machining Function: 
Creating a Pocket on the Face of the Part 
 
A practical programming application of the Mill End Polar machining function has been 
provided below.  This example assumes you have a knowledge of creating part geometry in the 
PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s Database and creating 
cycles in PartMaker’s Cycles Database. 
 
In the example given below, you will mill a Square Pocket .400 from side to side with a .08 
diameter End Mill. If you wish to complete this exercise on your own, make sure you have the 
following tools created in your PartMaker Tools Database (all tools used in the Mill End Polar 
Face Window should have an orientation of Z Tool) 

1. .080 Diameter End Mill 
 

 

 
Step 1. Create a Mill End Polar Machining Function Face Window 
 
Note: When creating a milled feature in PartMaker SwissCAM, you must always start with a 
turning operation.  Thus you must have a face window of machining function Turn created and 
at least one Turning part feature and tool path created (such as a facing operation). 
 
Start by creating a Mill End Polar Machining Function Face Window.  To do so: 

1. Enter the Setup dialog by choosing Setup from the View menu or by clicking on the 
Setup dialog icon in the upper left hand corner of the screen 

2. In the Setup dialog, click the New button create a new Machining Function face 
Window 

3. From the Machining Function drop down menu, choose Mill End, Polar 
 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Once the Setup dialog appears as above, click on Close 

 

Features to be created: 
 
Mill a square pocket with a .080 
dia. end mill 
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Step 2. Create Part Geometry 
 
Start by entering the CAD mode in the Mill End Polar Window. Draw the following features: 

1. Choose Show Axes  from the View Menu 
2. Choose Show Boundaries  from the View Menu 
3. Draw a square that is .400 from flat to flat. 
4. Draw a .0625 inch radius using the Fillet Icon to round off each corner 

 
Your completed geometry and CAD Face Window should appear as shown below: 
 

 
 

Note: You can always go to a different Face Window in your *.job file by selecting from the 
Window menu.  Additionally, you can toggle between different Face Windows within the active 
face Window by choosing Show Windows Icons  from the View menu and double clicking on 
the icon representing the Window you want to view. 
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Step 3. Create Part Features and assign tool paths 
 
Start by entering the CAM mode in the Mill End, Polar Window. First you will create the tool 
path to mill the square. To do so: 
 

1. From the Part Features  menu, choose New Profile Group 
2. Choose Pocket Mill under Cycle Type 
3. Choose Spiral for the type of pocket to be performed 
4. Enter a Z_Depth of 0.25 
5. Enter a Tool Diameter of .08 for the Roughing and Finishing and click Select Tools  
6. In the Cycle Name field, type Mill Pocket 

 
Your completed Profile Group Parameters dialog should appear as shown below: 

 

 
 

7. Assign the part feature to the square drawn earlier by clicking the Chain Geometry 
icon and clicking on the geometry to create the tool path.  It should appear as shown 
below: 
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8. From the Part Features menu, choose Verify Tool Path  to see the tool path as shown 
below: 

 
Choose Hide Work Tool Path to hide the tool path. 
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Machining Function: Mill Diam, Polar  
 

The Mill Diam, Polar machining function supports polar milling anywhere on the stock using an 
X-axis oriented milling tool. This machining function assumes that your CNC Swiss-type lathe 
has the ability to perform simultaneous feed motions with the X, Z and C-axes. The Mill Diam, 
Polar machining function is most commonly used to machine polygon features on the OD of the 
part using continuous C-axis feed.  Programming of this type in Face Windows  is carried out in 
much the same manner as the Mill Polygon machining function. 
 
Programming of this machining function requires that your CNC Swiss-type lathe has a 
programmable C-axis and that you have purchased the PartMaker C-axis milling option. 

 

 
 

Length (L) Length of the finished part  

OD Starting outside diameter of bar stock before machining 

ID Starting inside diameter of bar stock before machining  
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Types of Features Created in Mill Diam Polar Machining Function Window 
 

The Mill Diam Polar window uses an X-oriented “live” tool. There is polar C-axis movement 
(the C-axis does not lock).  This window is most commonly used to machine flats when a Y-axis 
motion is not available. Because many Swiss Machines come equipped with a Y-axis and such 
tool motion is less precise, the Mill Diam Polar window is not a commonly used window 
because you can achieve better and more efficient results using the Mill Polygon Machining 
function.  
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Part Features Dialogs Available in Mill Diam Polar Machining Function  
 
The Mill Diam Polar machining function can be used to create flats only.  Below, a Profile 
Group parameter window is shown.   

 
Note: In the Mill Diam Polar window you are only allowed to use New Profile Group. A New 
Hole Group is not accessible, 

 
 

 

 

 

 

 

 

 

 

 

 

 

Graphics Icons – Machining Functions for Mill Diam Polar  
The Machining Functions, Mill Diam Polar use some or all of the following icons to allow you 
to assign part features to created geometry in order to create a tool path. 
 

 
Define Profile Icon  enables you to specify that the currently active group symbol is to 
be applied to the profile described by either coordinate entry or by clicking on geometric 
elements. 

 
Chain Geometry Icon enables you to specify that the currently active group symbol is 
to be applied to a profile that is created when PartMaker automatically connects all the 
elements that form an unbroken chain with an initial line or arc clicked. 

Distance From Part 
Face, To: 

Indicates placement of tool with respect to the part face.  The tool 
can be positioned with respect to the Left Tool Edge (P1), the Tool 
Center (P2) or the Right Tool Edge (P3).   

X_Surf (S) Establishes the X-zero work plane, i.e. a value 0.25 indicates the X-
zero work plane is .25 from the center of the part. 

X_Rapid (R) Specifies how much clearance the tool will rapid above your X_Surf 

Clearance(C) Specifies the clearance amount the tool will position past the 
barstock diameter. 
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Machining Function: Mill Cylinder 
 
The Mill Cylinder machining function supports continuous milling on the outside diameter of the 
part.  Cylindrical milling assumes that your CNC Swiss-type lathe has the ability to 
simultaneously feed in the X, Z and C axes. 
 
Using motions of this type, combined with a tool oriented along the X axis of the machine, 
profiles can be created on the outside diameter of the stock. 
 
Tool positioning is programmed using X, Z, and C axis coordinates.  The C posit ion is 
programmed in terms of degrees of rotation relative to machine C=0 which is clearly shown in 
the graphic below. 
 
Programming of this machining function requires that your CNC Swiss-type lathe has a 
programmable C-axis and that you have purchased the PartMaker C-axis milling option. 
 

 
 

Length (L) Length of the finished part  

OD Diameter of the surface to be machined 

ID Starting inside diameter of bar stock before machining  
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Types of Features Created in Mill Cylinder Machining Function Window 

 
The Mill Cylinder window uses an X-oriented “live” tool. There is polar c-axis movement (the c-
axis does not lock).  This window is mainly used for doing contoured pockets and or slots as 
well as engraving.   
 
The features shown on the parts below are representative examples of features that can be 
created in the Mill Cylinder window.  The *.job, *.cdb and *.tdb files used to create some of 
these parts can be found on in the in the Sample directory which was installed when you initially 
installed PartMaker SwissCAM.  Where relevant, the locations of these files have been provided. 

 

  
Figure 1. J-Slot 
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Hardinge_ST\HardingeST.job, 
HardingeST.cdb, HardingeST.tdb) 
 

Figure 2. Engraving 
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Hardinge_ST\Hardinge-Caxis.job, 
Hardinge-Caxis.cdb, Hardinge-Caxis.tdb) 
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Part Features Dialogs Available in Mill Cylinder Machining Function 
 
The Mill Cylinder machining function can be used to create Contours, Pockets and Lettering on the 
outside diameter.  Below, a Contour Mill cycle with tool motion on centerline is shown.  Cutter 
compensation can also be used by choosing Left or Right  from the Tool Position drop down 
menu. 

 

 

 

 

 

 

Cycle Type Indicates the type of feature to be milled, 
either a Contour Mill or Pocket Mill 

Tool Position 

For Contour Mill indicates the tool 
position during cutting, such as Left 
(climb milling), Right (conventional 
milling) or On (on centerline milling) 

X_Surf (S) Establishes the X-zero work plane, i.e. a 
value 0.25 indicates the X-zero work 
plane is .25 from the center of the part. 

X_Depth (D) The depth of the operation to be 
performed 

X_Rapid (R) Specifies how much clearance the tool 
will rapid to above your X_Surf. 

Bottom Finish (b) Amount of material left on the bottom of 
the feature for the finishing end mill to 
remove 

Wall Finish (w) Amount of material left on the side (or 
wall) of the feature for the finishing end 
mill to remove 

Roughing/Finishing Indicates whether a Roughing and/or 
Finishing Tool will be used 

Ramping Indicates the manner of entry of end mill 
into a feature, either Vertical, Helical, 
Sloped or Sloped Down and Return 
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Graphics Icons-Machining Functions for Mill Cylinder 
The Machining Functions for Mill Cylinder use some or all of the following icons to allow you 
to assign part features to created geometry in order to create a tool path. 
 

 
Define Profile Icon  enables you to specify that the currently active group symbol is to 
be applied to the profile described by either coordinate entry or by clicking on geometric 
elements. 

 
Chain Geometry Icon enables you to specify that the currently active group symbol is 
to be applied to a profile that is created when PartMaker automatically connects all the 
elements that form an unbroken chain with an initial line or arc clicked. 

 
Engrave Icon enables you to use the Engrave Data dialog box to create a profile 
containing numbers and letters. 

 
Programming Examples using the Mill Cylinder Machining Function: 
 
A practical programming application of the Mill Cylinder machining function has been provided 
below.  This example assumes you have a knowledge of creating part geometry in the PartMaker 
CAD mode as well as creating tools in PartMaker’s Tool’s Database and creating cycles in 
PartMaker’s Cycles Database. 
 
Example A: Engraving on the Outside Diameter 
In the example given below, you will engrave the words “PartMaker” with a ¼ inch Spot Drill. If 
you wish to complete this exercise on your own, make sure you have the following tools created 
in your PartMaker Tools Database (all tools used in the Mill Cylinder Face Window should have 
an orientation of X Tool) 

1. .25 Inch Spot Drill 
 

 

 
Step 1. Create a Mill Cylinder Machining Function Face Window 
 
Note: When creating a milled feature in PartMaker SwissCAM, you must always start with a 
turning operation.  Thus you must have a face window of machining function Turn created and 
at least one Turning part feature and tool path created (such as a facing operation). 
 
Start by creating a Mill Cylinder Machining Function Face Window.  To do so: 
 

1. Enter the Setup dialog by choosing Setup from the View menu or by clicking on the 
Setup dialog icon in the upper left hand corner of the screen 

2. In the Setup dialog, click the New button create a new Machining Function face 
Window 

3. From the Machining Function drop down menu, choose Mill Cylinder 
 

 

Features to be created: 
 
Engraving with the words 
“PARTMAKER” on the Outside 
Diameter 
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4. Enter the setup parameters as shown below: 
 
 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
Once the Setup dialog appears as above, click on Close 
 
Step 2. Create Part Features 
 
Note: When performing engraving it is not necessary to create part geometry. 
 
Start by entering the CAM mode in the Mill Cylinder Window.  

1. Choose Show Axes  from the View Menu 
2. Choose Show Boundaries  from the View Menu 
3. From the Part Features  menu, choose the New Profile Group. 
4. Choose Contour Mill under Cycle Type 
5. Choose ON from Tool Position  to indicate that we will be working on centerline with 

the tool. 
6. Enter an X_Surf of 0.3125 
7. Enter an X_Depth of 0.025 
8. Enter the Tool ID number of the 0.25 diameter Spot Drill created and click on Select 

Tools  
9. When all of the necessary data has been entered click on Close 
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Step 3. Create Text 
 

1. Click on the Engraving Icon and you will get the following dialog box shown below. 
2. Type the word “Partmaker” in the box shown below then click on OK. 

 

 
 
3. Drag a window around the text “PartMaker” and choose the Rotate command under 

Edit menu you will get the following dialog box shown below. 
4. Fill in all the necessary information from the dialog box below. 

       
5. When all of the necessary data has been entered click on OK 

 
Your completed geometry should appear as shown below: 
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1. From the Part Features menu, choose Verify Tool Path  to see the tool path as shown 

below: 
 
 

 
Choose Hide Work Tool Path to hide the tool path. 
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Example B: Milling a Contoured Pocket 

 
In the example given below, you will mill a contoured pocket on the diameter with a 1/8-inch 
End Mill. If you wish to complete this exercise on your own, make sure you have the following 
tools created in your PartMaker Tools Database (all tools used in the Mill Cylinder Face 
Window should have an orientation of X Tool ) 

1. .125 Inch Diameter End Mill 
 

 

 
Step 1. Create a Mill Cylinder Machining Function Face Window 
 
Note: When creating a milled feature in PartMaker SwissCAM, you must always start with a 
turning operation.  Thus you must have a face window of machining function Turn created and 
at least one Turning part feature and tool path created (such as a facing operation). 
 
Start by creating a Mill Cylinder Machining Function Face Window.  To do so: 

1. Enter the Setup dialog by choosing Setup from the View menu or by clicking on the 
Setup dialog icon in the upper left hand corner of the screen 

2. In the Setup dialog, click the New button create a new Machining Function face 
Window 

3. From the Machining Function drop down menu, choose Mill Cylinder 
4. Enter the setup parameters as shown below: 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Features to be created: 
 
Mill a Contoured Pocket with a 
.125 diameter End Mill. 
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Step 2. Create Part Geometry 
 
Start by entering the CAD mode in the Mill Cylinder Window. Draw the following features: 

1. Choose Show Axes  from the View Menu 
2. Choose Show Boundaries  from the View Menu 
3. Draw a ½ square with .125 radius corners anywhere in the boundaries. 

 
Your completed geometry and CAD Face Window should appear as shown below: 
 

 
 

Note: You can always go to a different Face Window in your *.job file by selecting from the 
Window menu.  Additionally, you can toggle between different Face Windows within the active 
Window by choosing Show Windows Icons  from the View menu and double clicking on the 
icon representing the Window you want to view. 
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Step 3. Create Part Features and assign tool paths 
 
Start by entering the CAM mode in the Mill Cylinder Window. First you will create the tool path 
to mill the square. To do so: 
 

1. From the Part Features  menu, choose New Profile Group 
2. Choose Pocket Mill under Cycle Type 
3. Enter a X_Depth of 0.15 
4. Enter a Tool Diameter of 0.125 and click Select Tools  
5. In the Cycle Name field, type Mill Pocket 

 
Your completed Profile Group Parameters dialog should appear as shown below: 

 

 
 

6. Assign the part feature to the square drawn earlier by clicking the Chain Geometry 
icon and clicking on the geometry to create the tool path.  It should appear as shown 
below: 
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7. From the Part Features menu, choose Verify Tool Path  to see the tool path as shown 
below: 

 
Choose Hide Work Tool Path to hide the tool path. 

 
 


